読者です 読者をやめる 読者になる 読者になる

kubo39's blog

ただの雑記です。

list-packagesで選択したやつがダウンロードできなかった

すごい今更自宅のノートPCでemacs24をaptから入れたんだけど、list-packagesで選択したパッケージがダウンロードできないという状況にぶちあたった。

Debugger entered--Lisp error: (error "Packageemacs-24.1' is unavailable")`

みたいなエラーが出てる。ググって他の解決策みるとsnapshotでバージョン上げろ、みたいなのしかなかった。

まあ、なので https://launchpad.net/~ubuntu-elisp/+archive/ubuntu/ppa からemacs-snapshotを引っ張ってくる。

$ sudo add-apt-repository ppa:ubuntu-elisp/ppa
$ sudo aptitude update
$ sudo aptitude install emacs-snapshot

とりあえずpackageまわり動くようになった。